using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z]+(?:(?:, |-)[A-Za-z]+)*$";
string input = @"A
Az
A-z
A-z, By
Латиница верхний нижний регистр ([A-Za-z])
Пробел, запятая, тире.
Строка начинается и заканчивается с литеры (любой).
Тире только между литерами.
Запятая только перед пробелом после литеры";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}