import Foundation
let pattern = #"^[A-Za-z]+(?:(?:, |-)[A-Za-z]+)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A
Az
A-z
A-z, By
Латиница верхний нижний регистр ([A-Za-z])
Пробел, запятая, тире.
Строка начинается и заканчивается с литеры (любой).
Тире только между литерами.
Запятая только перед пробелом после литеры
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)