import re
regex = re.compile(r"^[A-Za-z]+(?:(?:, |-)[A-Za-z]+)*$", flags=re.MULTILINE)
test_str = ("A\n"
"Az\n"
"A-z\n"
"A-z, By\n\n\n"
"Латиница верхний нижний регистр ([A-Za-z])\n"
"Пробел, запятая, тире.\n"
"Строка начинается и заканчивается с литеры (любой).\n"
"Тире только между литерами.\n"
"Запятая только перед пробелом после литеры")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")