re = /^[A-Za-z]+(?:(?:, |-)[A-Za-z]+)*$/m
str = 'A
Az
A-z
A-z, By
Латиница верхний нижний регистр ([A-Za-z])
Пробел, запятая, тире.
Строка начинается и заканчивается с литеры (любой).
Тире только между литерами.
Запятая только перед пробелом после литеры'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end