import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z]+(?:(?:, |-)[A-Za-z]+)*$";
final String string = "A\n"
+ "Az\n"
+ "A-z\n"
+ "A-z, By\n\n\n"
+ "Латиница верхний нижний регистр ([A-Za-z])\n"
+ "Пробел, запятая, тире.\n"
+ "Строка начинается и заканчивается с литеры (любой).\n"
+ "Тире только между литерами.\n"
+ "Запятая только перед пробелом после литеры";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}