# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^()]+|\(((?R)*+)\)/$1/g;t' <<< "ылпе(_4043()вапdsff)rtnbe"