const regex = /[^()]+|\(((?R)*+)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^()]+|\\(((?R)*+)\\)', 'g')
const str = `ылпе(_4043()вапdsff)rtnbe`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);