package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^()]+|\(((?R)*+)\)`)
var str = `ылпе(_4043()вапdsff)rtnbe`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}