#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^()]+|\(((?R)*+)\)"
Local $sString = "ылпе(_4043()вапdsff)rtnbe"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)