$re = '/[^()]+|\(((?R)*+)\)/';
$str = 'ылпе(_4043()вапdsff)rtnbe';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;