re = /[^()]+|\(((?R)*+)\)/
str = 'ылпе(_4043()вапdsff)rtnbe'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result