use strict;
my $str = 'ылпе(_4043()вапdsff)rtnbe';
my $regex = qr/[^()]+|\(((?R)*+)\)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";