#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)\h([a-zA-Z0-9]{8})$(?=.*\h\1$)"
Local $sString = "Folder A\Folder C\File three.txt 56efd95f" & @CRLF & _
"Folder A\File one.txt b8e1b873" & @CRLF & _
"Folder A\Folder B\Folder D\File four.txt 56efd95f" & @CRLF & _
"Folder A\Folder B\File two.txt 21e8e9c9"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)