using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\h([a-zA-Z0-9]{8})$(?=.*\h\1$)";
string substitution = @"$1";
string input = @"Folder A\Folder C\File three.txt 56efd95f
Folder A\File one.txt b8e1b873
Folder A\Folder B\Folder D\File four.txt 56efd95f
Folder A\Folder B\File two.txt 21e8e9c9";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}