import re
regex = re.compile(r"(?s)\h([a-zA-Z0-9]{8})$(?=.*\h\1$)", flags=re.MULTILINE)
test_str = ("Folder A\\Folder C\\File three.txt 56efd95f\n"
"Folder A\\File one.txt b8e1b873\n"
"Folder A\\Folder B\\Folder D\\File four.txt 56efd95f\n"
"Folder A\\Folder B\\File two.txt 21e8e9c9")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)