const regex = /(?s)\h([a-zA-Z0-9]{8})$(?=.*\h\1$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)\\h([a-zA-Z0-9]{8})$(?=.*\\h\\1$)', 'gm')
const str = `Folder A\\Folder C\\File three.txt 56efd95f
Folder A\\File one.txt b8e1b873
Folder A\\Folder B\\Folder D\\File four.txt 56efd95f
Folder A\\Folder B\\File two.txt 21e8e9c9`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);