use strict;
my $str = 'Folder A\\Folder C\\File three.txt 56efd95f
Folder A\\File one.txt b8e1b873
Folder A\\Folder B\\Folder D\\File four.txt 56efd95f
Folder A\\Folder B\\File two.txt 21e8e9c9';
my $regex = qr/(?s)\h([a-zA-Z0-9]{8})$(?=.*\h\1$)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";