#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)^" & @CRLF & _
"(?=.*?\bone\b)" & @CRLF & _
"(?=.*?\btwo\b)" & @CRLF & _
"(?=.*?\bthree\b)" & @CRLF & _
"(?!\t.*?)" & @CRLF & _
"" & @CRLF & _
".*" & @CRLF & _
"$"
Local $sString = "only if line contauins one two three it matches" & @CRLF & _
"only if line contauins one two three it matches and has no tabs " "" & @CRLF & _
"here two whatever" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")