const regex = /^
(?=.*?\bone\b)
(?=.*?\btwo\b)
(?=.*?\bthree\b)
(?!\t.*?)
.*
$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(?=.*?\\bone\\b)
(?=.*?\\btwo\\b)
(?=.*?\\bthree\\b)
(?!\\t.*?)
.*
$', 'gm')
const str = `only if line contauins one two three it matches
only if line contauins one two three it matches and has no tabs " "
here two whatever
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}