$re = '/^
(?=.*?\bone\b)
(?=.*?\btwo\b)
(?=.*?\bthree\b)
(?!\t.*?)
.*
$/xm';
$str = 'only if line contauins one two three it matches
only if line contauins one two three it matches and has no tabs " "
here two whatever
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);