package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^
(?=.*?\bone\b)
(?=.*?\btwo\b)
(?=.*?\bthree\b)
(?!\t.*?)
.*
$`)
var str = `only if line contauins one two three it matches
only if line contauins one two three it matches and has no tabs " "
here two whatever
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}