use strict;
my $str = 'only if line contauins one two three it matches
only if line contauins one two three it matches and has no tabs " "
here two whatever
';
my $regex = qr/^
(?=.*?\bone\b)
(?=.*?\btwo\b)
(?=.*?\bthree\b)
(?!\t.*?)
.*
$/xmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}