import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?=.*?\\bone\\b)\n"
+ "(?=.*?\\btwo\\b)\n"
+ "(?=.*?\\bthree\\b)\n"
+ "(?!\\t.*?)\n\n"
+ ".*\n"
+ "$";
final String string = "only if line contauins one two three it matches\n"
+ "only if line contauins one two three it matches and has no tabs \" \"\n"
+ "here two whatever\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}