import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.* you.*$";
final String string = "4\n"
+ "00:00:24.067 --> 00:00:35.924\n"
+ "Hi, how are you?\n"
+ "Doing fine?\n\n"
+ "5\n"
+ "00:00:35.926 --> 00:00:47.264\n"
+ "I'm doing the best I can.\n"
+ "And you?\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}