re = /^.* you.*$/mi
str = '4
00:00:24.067 --> 00:00:35.924
Hi, how are you?
Doing fine?
5
00:00:35.926 --> 00:00:47.264
I\'m doing the best I can.
And you?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end