import re
regex = re.compile(r"^.* you.*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("4\n"
"00:00:24.067 --> 00:00:35.924\n"
"Hi, how are you?\n"
"Doing fine?\n\n"
"5\n"
"00:00:35.926 --> 00:00:47.264\n"
"I'm doing the best I can.\n"
"And you?\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")