$re = '/^.* you.*$/mi';
$str = '4
00:00:24.067 --> 00:00:35.924
Hi, how are you?
Doing fine?
5
00:00:35.926 --> 00:00:47.264
I\'m doing the best I can.
And you?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);