// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^.* you.*$").unwrap();
let string = "4
00:00:24.067 --> 00:00:35.924
Hi, how are you?
Doing fine?
5
00:00:35.926 --> 00:00:47.264
I'm doing the best I can.
And you?
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}