const regex = /^.* you.*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.* you.*$', 'gmi')
const str = `4
00:00:24.067 --> 00:00:35.924
Hi, how are you?
Doing fine?
5
00:00:35.926 --> 00:00:47.264
I'm doing the best I can.
And you?
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}