#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http:\/\/localhost:3000\/v2\/manufacturers\/?(?:\?\S+|\d+\/\S+)?$"
Local $sString = "http://localhost:3000/v2/manufacturers?enabled=true" & @CRLF & _
"http://localhost:3000/v2/manufacturers/" & @CRLF & _
"http://localhost:3000/v2/manufacturers" & @CRLF & _
"http://localhost:3000/v2/manufacturers/1/models" & @CRLF & _
"" & @CRLF & _
"http://localhost:3000/v2/manufacturers/1" & @CRLF & _
"http://localhost:3000/v2/manufacturers/123" & @CRLF & _
"http://localhost:3000/v2/manufacturers/1?enabled=true"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")