$re = '/^http:\/\/localhost:3000\/v2\/manufacturers\/?(?:\?\S+|\d+\/\S+)?$/m';
$str = 'http://localhost:3000/v2/manufacturers?enabled=true
http://localhost:3000/v2/manufacturers/
http://localhost:3000/v2/manufacturers
http://localhost:3000/v2/manufacturers/1/models
http://localhost:3000/v2/manufacturers/1
http://localhost:3000/v2/manufacturers/123
http://localhost:3000/v2/manufacturers/1?enabled=true';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);