import re
regex = re.compile(r"^http:\/\/localhost:3000\/v2\/manufacturers\/?(?:\?\S+|\d+\/\S+)?$", flags=re.MULTILINE)
test_str = ("http://localhost:3000/v2/manufacturers?enabled=true\n"
"http://localhost:3000/v2/manufacturers/\n"
"http://localhost:3000/v2/manufacturers\n"
"http://localhost:3000/v2/manufacturers/1/models\n\n"
"http://localhost:3000/v2/manufacturers/1\n"
"http://localhost:3000/v2/manufacturers/123\n"
"http://localhost:3000/v2/manufacturers/1?enabled=true")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")