package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http:\/\/localhost:3000\/v2\/manufacturers\/?(?:\?\S+|\d+\/\S+)?$`)
var str = `http://localhost:3000/v2/manufacturers?enabled=true
http://localhost:3000/v2/manufacturers/
http://localhost:3000/v2/manufacturers
http://localhost:3000/v2/manufacturers/1/models
http://localhost:3000/v2/manufacturers/1
http://localhost:3000/v2/manufacturers/123
http://localhost:3000/v2/manufacturers/1?enabled=true`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}