import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http:\\/\\/localhost:3000\\/v2\\/manufacturers\\/?(?:\\?\\S+|\\d+\\/\\S+)?$";
final String string = "http://localhost:3000/v2/manufacturers?enabled=true\n"
+ "http://localhost:3000/v2/manufacturers/\n"
+ "http://localhost:3000/v2/manufacturers\n"
+ "http://localhost:3000/v2/manufacturers/1/models\n\n"
+ "http://localhost:3000/v2/manufacturers/1\n"
+ "http://localhost:3000/v2/manufacturers/123\n"
+ "http://localhost:3000/v2/manufacturers/1?enabled=true";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}