// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^http:\/\/localhost:3000\/v2\/manufacturers\/?(?:\?\S+|\d+\/\S+)?$").unwrap();
let string = "http://localhost:3000/v2/manufacturers?enabled=true
http://localhost:3000/v2/manufacturers/
http://localhost:3000/v2/manufacturers
http://localhost:3000/v2/manufacturers/1/models
http://localhost:3000/v2/manufacturers/1
http://localhost:3000/v2/manufacturers/123
http://localhost:3000/v2/manufacturers/1?enabled=true";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}