const regex = /^http:\/\/localhost:3000\/v2\/manufacturers\/?(?:\?\S+|\d+\/\S+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http:\\\/\\\/localhost:3000\\\/v2\\\/manufacturers\\\/?(?:\\?\\S+|\\d+\\\/\\S+)?$', 'gm')
const str = `http://localhost:3000/v2/manufacturers?enabled=true
http://localhost:3000/v2/manufacturers/
http://localhost:3000/v2/manufacturers
http://localhost:3000/v2/manufacturers/1/models
http://localhost:3000/v2/manufacturers/1
http://localhost:3000/v2/manufacturers/123
http://localhost:3000/v2/manufacturers/1?enabled=true`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}