using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"\'{2,}";
        string substitution = @"'";
        string input = @"aaaaa''''a'''a''x1'sdd";
        RegexOptions options = RegexOptions.IgnoreCase;
        
        Regex regex = new Regex(pattern, options);
        string result = regex.Replace(input, substitution);
    }
}