use strict;
my $str = 'aaaaa\'\'\'\'a\'\'\'a\'\'x1\'sdd';
my $regex = qr/\'{2,}/ip;
my $subst = '\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";