// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\'{2,}").unwrap();
let string = "aaaaa''''a'''a''x1'sdd";
let substitution = "'";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}