$re = '/\'{2,}/i';
$str = 'aaaaa\'\'\'\'a\'\'\'a\'\'x1\'sdd';
$subst = "'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;