import re
regex = re.compile(r"\'{2,}", flags=re.IGNORECASE)
test_str = "aaaaa''''a'''a''x1'sdd"
subst = "'"
result = regex.sub(subst, test_str)
if result:
print(result)