using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:(?:"","")|(?:[^"",]*))*?)(?:,|$)";
string substitution = @"$1\n";
string input = @"3"","",3,4,f"",""3,"","","","","","",""3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}