$re = '/((?:(?:",")|(?:[^",]*))*?)(?:,|$)/m';
$str = '3",",3,4,f","3,",",",",","","3';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;