use strict;
my $str = '3",",3,4,f","3,",",",",","","3';
my $regex = qr/((?:(?:",")|(?:[^",]*))*?)(?:,|$)/mp;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";