const regex = /((?:(?:",")|(?:[^",]*))*?)(?:,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?:",")|(?:[^",]*))*?)(?:,|$)', 'gm')
const str = `3",",3,4,f","3,",",",",","","3`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);