package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:(?:",")|(?:[^",]*))*?)(?:,|$)`)
var str = `3",",3,4,f","3,",",",",","","3`
var substitution = "$1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}