import re
regex = re.compile(r"((?:(?:\",\")|(?:[^\",]*))*?)(?:,|$)", flags=re.MULTILINE)
test_str = "3\",\",3,4,f\",\"3,\",\",\",\",\",\"\",\"3"
subst = "$1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)