# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\S)[ ]{2,}(?=\S)/ /gm;t' <<< " def post(self, request, format=None):
action = request.query_params.get('action', None)
res = 'UNKNOWN ACTION'
hhtpstatus = status.HTTP_400_BAD_REQUEST
"