#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\S)[ ]{2,}(?=\S)"
Local $sString = " def post(self, request, format=None): " & @CRLF & _
" action = request.query_params.get('action', None)" & @CRLF & _
" res = 'UNKNOWN ACTION'" & @CRLF & _
" hhtpstatus = status.HTTP_400_BAD_REQUEST" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)