using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\S)[ ]{2,}(?=\S)";
string substitution = @" ";
string input = @" def post(self, request, format=None):
action = request.query_params.get('action', None)
res = 'UNKNOWN ACTION'
hhtpstatus = status.HTTP_400_BAD_REQUEST
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}